Subaru Solterra Forum banner

SUBARU SOLTERRA CONNECT recurring message on iPhone

528 Views 7 Replies 7 Participants Last post by  FelineFreddie
I’m hoping I’ve overlooked a simple fix for this issue:

Every time I’m near or enter my Solterra, the following message appears on my iPhone:
“SUBARU SOLTERRA CONNECT would like to communicate with the SUBARU Multimedia SOLTERRA.” See screenshot.

I select allow of course, and yet it asks again next time. Does anyone know how to change a setting to always allow this? I can’t seem to find any options in the iOS settings or the Solterra app settings.

I’d appreciate any insights.


Font Electric blue Terrestrial plant Event Brand
See less See more
1 - 8 of 8 Posts
That was normal with mine. I think it’s the Bluetooth connection. I tried everything. Unselecting the media. Checking Apple CarPlay and it still did it. Even uninstalled the app and reinstalled. Same thing.
My iPhone 14 shows the connect message, but I simply ignore it and soon afterwards it goes away.
  • Like
Reactions: 1
Yes, happens to ours at least a couple times a week. Thank you Toyota!
Bloody annoying. I know. I'd love to see an update come thru to get rid of that.
  • Like
Reactions: 1
Seems to be no difference in any functionality if you ignore vs allow. I mentioned it to the re-delivery tech who also didn't know why that was, but promised he would pass it along as an annoyance
It is annoying. I finally convinced myself yesterday that ignoring it was fine - in that it didn't speed up or slow down the already too slow syncing of my settings. I find the nags annoying. But the fact I cannot seem to just start the car in drive off without carplay maybe not syncing until I stop again worse.

Still love the car though :)
Try rebooting the infotainment system by holding down the power button for several seconds, between the volume controls, until the screen goes blank and restarts.
  • Like
Reactions: 1
1 - 8 of 8 Posts
Top